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Introducing Repute 2.5 
Repute® provides a rich set of capabilities for engineers to design/analyse: 

• various types of single pile, using current and historical design 

standards (such as Eurocode 7 and BS 8004:2015) 

• pile groups under generalized 3-dimensional loading, using linear of 

non-linear soil models 

Repute considers single pile response using a variety of calculation methods 

for ultimate and serviceability limit states. Both traditional lumped factors-of-

safety and modern partial factors can be applied in these calculations. 

Repute analyses pile group behaviour using the boundary element method, 

employing the leading analytical program PGroupN (developed by and 

included under exclusive licence from Geomarc). PGroupN provides a 

complete 3D non-linear boundary element solution of the soil continuum, 

which overcomes limitations of traditional interaction factor methods and 

gives more realistic predictions of deformations and the load distribution 

between piles. 

What’s new in Repute 2.5? 

New features 

• Multi-threaded boundary element engine, up to 100x faster than 

before 

• Support for spun piles and micropiles 

• Action Import Wizard 

• Pile Group Import Wizard 

• Ability to choose which sections and materials appear in the 

Stockyard 

• Support for BS 8004:2015 

• Direct support for rock within the boundary element analysis 

Improved features  

• Pile Group Wizard now supports a wider range of pile types 
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• Greater distinction between different calculations in Stockyard 

• Updated Quick-Start Tutorial 

• Support for using the program across wide area networks 

• Numerous other minor improvements 

Documentation 
Repute is supplied with a detailed Quick-start Guide, comprehensive User 

Manual, and authoritative Reference Manual. The latest versions of these 

manuals (including any corrections and/or additions since the program’s first 

release) are available in electronic (Adobe® Acrobat®) format from the 

Geocentrix website. (www.geocentrix.co.uk/repute and follow links to 

Repute’s documentation). 

Quick-Start guide (this document) 

The Repute 2.5 Quick-Start Guide includes six tutorials that show you how to 

use the main features of Repute. Each tutorial provides step-by-step 

instructions on how to drive the program. There are three tutorials dealing 

with single pile design and three with pile group design. The tutorials increase 

in difficulty and are designed to be followed in order. 

User manual 

The Repute 2.5 User Manual explains how to use Repute. It provides a 

detailed description of the program’s user interface and explains how to 

employ it to maximum effect. 

Reference manual 

The Repute 2.5 Reference Manual gives detailed information about the 

engineering theory that underpins Repute’s calculations. The manual 

assumes you have a working knowledge of the geotechnical design of single 

piles and pile groups but provides appropriate references for further study if 

you do not. 

Help system 

Repute’s help system contains detailed information about the program, 

including most of the content of the Quick-Start Guide, User Manual, and 
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Reference Manual – plus additional information that is not found in any of 

these documents. 

Help appears in a separate window to Repute, allowing you to view the help 

topics while you continue to work with Repute itself. To open the help 

system: 

• Press F1 

• Click the Help button in any dialog box 

• Click on the Help button on the right-hand side 

of Repute’s Ribbon 

Note 

Screenshots in this document were produced on Windows 10 and 11. Their 

appearance may differ on your computer. Not all options are available in 

every edition of Repute. 

In this document, ‘[Docs]’ refers to the folder where the documents that 

ship with Repute were installed, typically here: 

C:\Users\Public\Documents\Geocentrix\Repute\2.5 

Software Re-Assurance™ 
Software Re-Assurance for Repute (including updates, upgrades, and 

technical support) is available direct from Geocentrix or through your local 

distributor. To obtain Re-Assurance, contact Geocentrix as follows: 

Repute Technical Support 

Geocentrix Ltd 

Scenic House, 54 Wilmot Way, Banstead, Surrey, SM7 2PY, United Kingdom 

tel: +44 (0)1737 373963 

email: support@geocentrix.co.uk 

web: www.geocentrix.co.uk/support 

Please quote your licence number when contacting technical support  

mailto:support@geocentrix.co.uk
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Tutorial 1. H-pile in clay and sand 
Introduction 
This tutorial demonstrates the basic features of Repute, through a worked 

example involving the analysis of a single H-pile installed in clay and sand: 

• Ground conditions comprise 5 m of clay overlying 20 m of dense 

sand. The clay has unit weight of 20.5 kN/m3, angle of shearing 

resistance of 23 , and undrained shear strength of 60 kPa. The sand 

has unit weight of 18 kN/m3 and angle of shearing resistance of 35.  

• The foundation comprises a 305 x 305 x 110 H-pile of steel grade 

S275. 

• A vertical load of 700 kN is to be applied to the pile. 

• You want to determine the minimum length of pile needed to safely 

carry the applied action according to traditional UK practice. 

This tutorial is written for users of the Standard, Enterprise, and Trial Editions 

of Repute only. Users of the Professional Edition should look at Tutorials 4-6. 

Overview 

• In Step 1, you will use the Project Wizard to enter project 

information, select a design standard, and create scenarios to 

represent short- and long-term conditions. 

• In Step 2, you will use the Borehole Wizard to create a borehole 

containing clay and sand layers. 

• In Step 3, you will create an H-pile and specify its cross-section and 

steel grade. 

• In Step 4, you will create the force applied to the pile. 

• In Step 5, you will use the Calculation Wizard to create the 

calculations you want Repute to perform. 

• In Step 6, you will perform the calculations and review the results. 

• In Step 7, you will produce a report summarising the results of the 

calculations. 

• In Step 8, you will close (and optionally save) the project. 



R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e    P a g e  | 11 
 

 

If Repute is not already running, open the program by pressing the Windows 

key, typing Repute 2.5 in the search bar, and clicking on the Repute 

2.5 item that should appear. Once the splash screen has disappeared, 

Repute displays its Welcome screen. 

If you have an existing project open, click Close on the program’s File menu. 

(You will be prompted to save your work if you have not already done so.) 

Step 1 – create the project 
In Step 1, you will use the Project Wizard to enter project information, select 

a design standard, and create scenarios to represent short- and long-term 

conditions. 

1. Open the Project Wizard by 

selecting the Wizards tab on 

Repute’s ribbon and clicking 

on the Project Wizard 

button. 

2. When the Wizard appears, type Tutorial 1 in the Project 

name box. Choose the folder where you want to save this project 

by using the Path control. (If you do not change the setting here, 

it will be saved in your Documents folder.) 

3. Enter H-pile in clay and sand in the Description box 

and 01 in the Project ID box. 
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4. Click Next to display the next page (the standards that appear 

depend on which edition of Repute you are running). Select BS 

8004:2015 by clicking on the relevant checkbox (a tick mark 

appears when a standard is selected). 

5. Click Next to display the next page. Increase the Number of 

scenarios to 2 and then change the Design Situation of Scenario 

1 to Transient but leave Scenario 2 as Persistent. 

6. Click Next to display the final page. If you wish to review any of 

the settings you have made, click Back to return to the relevant 

page. 

7. When you are ready, click Finish to generate the project. The 

Project Wizard then: 

• creates Site 1, Ground Surface 1, Design 

Standard 1, Situation 1, and Situation 2 

• adds Ground Surface 1 to Situation 1 and 
Situation 2 

• creates and saves a new project named Tutorial 1.rpx 

with all these items 
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8. You can view these items by right-

clicking anywhere inside the Project 

Manager to display its context menu 

and selecting the Expand All 

command. The Project Manager will 

then look as shown in the picture 

alongside. 

9. To view the properties of any 

particular item, select that item in the 

Project Manager (e.g. Site 1) 

10. Display the Property Inspector for the 

item: 

• by right-clicking on the item, to display its context menu, and 

clicking the Properties... command; or 

• by double-clicking on the item 

11. The program’s Property Inspector will 

open and display the properties of 

the selected item. (For example, for 

Site 1 the Description is shown as H-

pile in clay and sand and 

the Project ID as 01.) 

[Docs]\Tutorials\Tutorial 1\Step 1.rpx captures everything 

you’ve done so far. 

Step 2 – create the borehole 
In Step 2, you will use the Borehole Wizard to create a borehole containing 

clay and sand layers. 

1. Open the Borehole Wizard by 

selecting the Wizards tab on 

Repute’s ribbon and then 

clicking on the Borehole 

Wizard button. 
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2. When the Wizard appears, increase the number of layers to 2. 

3. Click Next to display page 2 of the Wizard. Change Layer 1 to 

Clay, its Thickness to 5 m, and its Weight density to 20.5 

kN/m3. Leave Layer 2 as Sand but change its thickness to 20 m 

and weight density to 18 kN/m3. 

4. Click Next to display page 3. Change the Internal friction of Layer 

1 to 23 and that of Layer 2 to 35. Leave the Cohesion of both 

soils unchanged at 0 kPa and the At Critical State? boxes 

unchecked. 

5. Click Next to display page 4. Change the Undrained Strength 

(top) and Undrained Strength (bottom) of Layer 1 to 60 kPa. 

Note that Soil 2 does not appear on this page, since – being a 

sand – it does not have undrained strength. 

6. Click Next to display page 5. Since the ground profile does not 

include rock, there is nothing to set on this page. 

7. Click Next to display page 6. Leave the stiffness properties (i.e. 

Shear modulus) of both layers unchanged. 
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8. Click Next to display page 7. Click All to 

select both scenarios. 

9. Click Next to display the final page. If you 

wish to review any of the settings you have 

made, click Back to return to the relevant 

page. 

10. When you are ready, click Finish to generate 

the borehole. The Borehole Wizard then: 

• creates Soil 1 and Soil 2, Layer 

1 and Layer 2, and Borehole 1 

• links Soil 1 to Layer 1 

• links Soil 2 to Layer 2 

• adds Layer 1 and Layer 2 to Borehole 1 

[Docs]\Tutorials\Tutorial 1\Step 2.rpx captures everything 

you’ve done so far. 

Step 3 – create the pile 
In Step 3, you will create an H-pile and specify its cross-section and steel 

grade. 

1. Open the 

Stockyard 

by selecting 

the View tab 

on Repute’s ribbon and then clicking on the Construct button. 

2. When the program has switched to its Construction Desktop (in 

which the Drawing Board, Project Manager, and Stockyard are 

displayed), right-click anywhere inside the Stockyard to display 

its context menu and select the Sections > Bearing Piles 

command. The Bearing Piles group will open. 
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3. Create the section by selecting the 

item labelled UKBP 305x305x95, 

right-clicking to display its context 

menu, and then selecting the 

command Create ‘UKBP 

305x305x95’. The newly created hot-

rolled section will appear in the 

Project Manager (under Sections > 

Bearing Piles) as Section 1. 

4. Next, right-click anywhere inside the 

Stockyard to display its context menu 

and select the Steels command. The 

Steels group will open. 

5. Create the steel by holding the Ctrl key down and clicking on the 

item labelled S275. (When the Ctrl key is pressed, Repute 

automatically creates any item that you select in the Stockyard. 

This saves you the effort of displaying the popup menu each time 

you want to create a new item.) The newly created steel will 

appear in the Project Manager (under Materials > Steels) as 

Steel 1. 

6. Finally, click on the Stockyard’s 

Structural Elements caption (near the 

bottom of the Stockyard). The 

Structural Elements panel will open. 

7. Create the pile by holding the Ctrl key 

down and clicking on the item 

labelled H-pile. The newly created 

pile will appear in the Project 

Manager (under Structural Elements 

> Piles) as Pile 1. 

8. In the Project Manager, right-click on 

Pile 1 to display its context menu and select the Properties... 

command. The Property Inspector will appear. 
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9. In the Property Inspector, change the Material Name (under 

Material Properties) from Not specified to Steel 1. Then 

change the Section Name (under Section Properties) from Not 

specified to Section 1. Leave all other properties of the 

pile unchanged. 

10. Returning to the Project Manager, 

select Situation 1 (under 

Scenarios > Situations) and, in its 

Property Inspector, place a tick next 

to Pile 1 (under Structural 

Elements) to add the pile to this 

scenario. The Drawing Board will refresh. 

11. Repeat the previous instruction for Situation 2. 

12. In this step, you have: 

• created Section 1, Steel 1, and Pile 1 

• linked Section 1 and Steel 1 to Pile 1 

• added Pile 1 to Situation 1 and Situation 2 

13. The Drawing Board will now look something like this: 

[Docs]\Tutorials\Tutorial 1\Step 3.rpx captures everything you’ve done so far. 
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Step 4 – create the force 
In Step 4, you will create the force applied to the pile. 

1. Open the 

Stockyard’s 

Actions 

panel by 

selecting the 

Insert tab on 

Repute’s ribbon and then clicking on the Action button. 

2. The Actions group will open in the Stockyard. Hold the Ctrl key 

down and click on the item labelled Force. 

3. The newly created force will appear in the Project Manager 

(under Actions > Forces). 

4. In the Property Inspector, change the 

Variability of Force 1 (under 

Options) to Permanent and the 

value of Fz (under Components of 

Action) to 700 kN. The Resultant will 

automatically change to 700 kN. 

5. Change the Tether to ... item to 

Pile 1. This will ensure that the 

force’s plan position will always 

match the pile’s plan position, even if the pile is moved. 

6. In the Project Manager, select Situation 1 (under Scenarios 

> Situations) and then, in its Property Inspector, place a tick next 

to Force 1 (under Actions) to add the action to this scenario. 

The Drawing Board will refresh and now look like this: 
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7. Repeat the previous instruction for Situation 2. 

8. In this step, you have: 

• created Force 1 

• added Force 1 to Situation 1 and Situation 2 

[Docs]\Tutorials\Tutorial 1\Step 4.rpx captures everything you’ve done so far. 

Step 5 – create the calculations 
In Step 5, you will use the Calculation Wizard to create the calculations you 

want to perform. 

1. Open the Calculation 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and then clicking 

on the Calculation 

Wizard button. 
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2. When the Wizard appears, select Longitudinal ULS. (The 

calculations that appear here depend on which edition of Repute 

you are running.) 

3. Click Next to display page 2 of the Wizard. Select Design 

Standard 1 (this is the BS 8004:2015 design standard created 

in Step 1 of this tutorial). 

4. Click Next to display page 3. Click All to select both situations. 

5. Click Next to display the final page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

6. When you are ready, click Finish to generate the calculations. 

7. The Calculation Wizard then: 

• creates Calculation 1 and Calculation 2 

• links Situation 1 to Calculation 1 

• links Situation 2 to Calculation 2 

• links Design Standard 1 to Calculation 1 and 
Calculation 2 

[Docs]\Tutorials\Tutorial 1\Step 5.rpx captures everything you’ve done so far. 

Step 6 – perform and review the calculations 
In Step 6, you will perform the calculations and review the results. 

1. Run the 

calculations 

by selecting 

the Build 

tab on Repute’s ribbon and then clicking on the Run All button.  



R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e    P a g e  | 21 
 

 

2. Repute will perform all 

the calculations that you 

have specified (i.e. 

Calculation 1 and 

Calculation 2) and 

then change to its 

Checking Desktop (which displays the Workbook and Graph 

Paper). You can switch to this display at any time by clicking on 

the Check button on the View tab of Repute’s ribbon.  

3. Your screen will now look something like this: 

 

4. The Graph Paper (top-centre panel) shows: 

• the effects-of-actions E (the sum of the applied forces and 

the self-weight of the pile) increasing slightly with depth 

• separate components of shaft and base resistances, Rs and Rb 
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• the total compressive resistance, Rc = Rs + Rb, exceeding the 

effect of actions (E ≤ Rc) at a depth between 13.5 and 14.5 m 

(depending on which calculation is displayed) 

5. The Workbook (top-left panel) shows 

the same information, but in tabular 

format. The Workbook contains a lot 

more information than is initially 

shown. To display this additional 

information, click on the button 

labelled * in the top-left-hand corner 

of the Workbook (to the left of the 

heading Depth) and select the data 

you want to see. 

6. The Message Board (bottom panel) 

shows any warning or error messages 

that were generated during the 

calculation. You should review these 

messages to ensure that the calculations have performed as you 

expected. 

7. To view the results of the second calculation, select 

Calculation 2 in the Project Manager. Repute will 

automatically update the Workbook and Graph Paper with this 

calculation’s data. 

[Docs]\Tutorials\Tutorial 1\Step 6.rpx captures everything you’ve done so far. 

Step 7 – produce a report  
In Step 7, you will produce a report summarising your calculations. 

1. Display Repute’s 

Reporter by selecting the 

View tab on the ribbon 

and then clicking on the 

Review button.  
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2. The Reporter will appear and automatically generate a report 

together with a set of thumbnails. 

 

3. You can navigate around the report using the controls on the 

Reporter tab on the ribbon: First Page, Previous Page, Next 

Page, and Last Page. You can jump to specific pages by clicking 

on the thumbnails on the left-hand side. 

4. You can also re-size the report using the Fit Width, Fit Height, 

Zoom In, and Zoom Out controls. 

5. You can choose what to include in your report by selecting or 

deselecting individual items in the Elements group, then clicking 

the Refresh button. 

6. Finally, you can output the report onto paper using the Print 

command and choosing from the options provided in the dialog 

box that appears on your screen. 
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Step 8 – close the project 
In Step 8, you will close and – optionally – save the project. (Note: this is not 

available in the Trial Edition.) 

1. Close the project by clicking on the File menu’s Close command. 

2. If you have made changes to the project since it was last saved, 

Repute will ask you if you want to save before proceeding. Click 

the appropriate button to answer Yes or No. 

3. Repute will then (if requested) save and close the project. 

You will find a copy of the project in its final form here: 
 

[Docs]\Tutorials\Tutorial 1\Tutorial 1.rpx 

What next? 
Tutorial 2 shows you how to perform Fleming’s hyperbolic analysis. 
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Tutorial 2. Fleming’s hyperbolic analysis 
Introduction 
Tutorial 2 shows you how to construct a load vs displacement curve for a 

single pile, using Fleming’s hyperbolic analysis, described in his 1992 

Géotechnique paper A new method for single pile settlement prediction and 

analysis (see vol. 42, no. 3, pp 411-425). This tutorial demonstrates how to 

setup a calculation in Repute without using the program’s built-in wizards, 

thereby showing you how versatile the program’s user interface is. 

The worked example is taken from Figure 6 in Fleming’s paper, which is based 

upon from tests carried out at Wembley by Whitaker and Cooke. We are 

interested in replicating the load vs displacement curve given by Fleming’s 

analysis. 

• Ground conditions at the site are not given in the paper, so we will 

assume 25 m of London Clay with an undrained strength of 100 kPa 

and internal friction angle of 23. 

• The pile studied is a 12.2 m long, 775 mm diameter bored pile made 

of concrete with Young’s modulus equal to 19.5 GPa. 

• A vertical load of 200 tonnes (approximately 2000 kN) is applied at 

the centre of the pile. 

• The ultimate load that the pile can carry has been calculated 

(separately) as 1994 kN on the shaft and 1002 kN from the base. The 

soil modulus below the pile base is 33.125 MPa. Other parameters 

used by Fleming are the shaft flexibility factor (0.0017 or 0.17%) and 

effective column length factor (0.45). 

This tutorial is written for users of the Standard, Enterprise, and Trial Editions 

of Repute only. Users of the Professional Edition should look at Tutorials 4-6. 

Overview 

• In Step 1, you will enter project information about the site and the 

Engineer. 

• In Step 2, you will define the site’s ground conditions. 
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• In Step 3, you will create a bored pile and specify its cross-section and 

concrete grade. 

• In Step 4, you will create the force applied to the pile. 

• In Step 5, you will sleeve the pile through the made ground. 

• In Step 6, you will create the scenario and calculation and link various 

items together. 

• In Step 7, you will perform the calculation and produce a report 

showing the relationship between load and displacement. 

• In Step 8, you will close (and optionally save) the project. 

If Repute is not already running, open the program by pressing the Windows 

key, typing Repute 2.5 in the search bar, and clicking on the Repute 

2.5 item that appears. Once the splash screen has disappeared, Repute 

displays its Welcome screen. 

If you have an existing project open, click Close on the program’s File menu. 

(You will be prompted to save your work if you have not already done so.) 

Step 1 – create the project information 
In Step 1, you will enter project information about the site and the Engineer. 

1. Click New on the program’s File menu 

to create a blank project. 

Alternatively, click on the New button 

on the Quick-access toolbar, located 

on the right-hand side of Repute’s icon in the tile bar. 

2. Open the Stockyard’s Project 

Information group by selecting the 

Insert tab on Repute’s ribbon and 

then clicking on the Project 

Information button.  

3. In the Stockyard, hold the Ctrl key down and click on the item 

labelled Construction Site. A newly created site will 

appear in the Project Manager (under Project Information > 

Project Information). 
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4. In the Project Manager, double-click on the newly created site 

(Site 1) to open its Property Inspector. 

5.  In the Property Inspector, change 

the Name to Wembley; enter 
Fleming’s hyperbolic 

analysis in the Description box 

and click OK to confirm what you 

have typed; and, finally, enter 

Figure 6 in the Project ID box. 

6. Returning to the Stockyard, create a Party by holding down the 

Ctrl key and clicking on the item labelled Party. A newly 

created party will appear in the Project Manager (under Project 

Information > Project Information) as Party 1 and the 

Property Inspector will display its default properties. 

7. In the Property Inspector, change the Name of the newly created 

party to Whitaker and Cooke and the role to Engineer (if 

not already selected). 

[Docs]\Tutorials\Tutorial 2\Step 1.rpx captures everything you’ve done so far. 
 

Step 2 – create the ground conditions 
In Step 2, you will define the site’s ground conditions. 



P a g e  | 28 R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e  
 

1. Returning to the Stockyard, click on 

the button labelled Common to open 

the Common group, where you will 

find (amongst other items) Plane 

Ground. 

2. Hold the Ctrl key down and click on 

the item labelled Plane Ground to 

create it. 

3. In the Property Inspector, change the 

Name Ground Surface 1 to 

Horizontal ground but leave 

the other (default) properties 

unchanged. 

4. Back in the Stockyard, open the 

Grounds group so that you can create 

a Clay. You may need to click one of 

the small buttons at the bottom of 

the Stockyard to display this group. 

You can move the mouse over each 

button in turn to display a tooltip indicating which panels they 

control. Create the Clay by Ctrl-clicking on it. 

5. In the Property Inspector, change the Name of the new Clay to 

London Clay and enter the following properties: under the 

heading Strength > Drained Strength, Peak friction = 23; under 

Strength > Undrained strength, Undrained strength = 100 kPa. 

6. In the Stockyard, open the Geotechnical Constituents group and 

create both a Soil Layer and a Borehole. 

7. Select Layer 1 in the Project Manager and then (in the 

Property Inspector) change its Name to Clay layer, its 

Thickness to 25 m, and select London Clay in its Soil box. 

8. Now select Borehole 1 in the Project Manager and (in the 

Property Inspector) rename it Wembley borehole. Next, 

press the Select ... button. 
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9. In the dialog box that appears, click on the >> button to move 

Clay layer from the Available layers box to the Selected 

layers box. Click OK to confirm the changes. 

 

[Docs]\Tutorials\Tutorial 2\Step 2.rpx captures everything you’ve done so far. 
 

Step 3 – create the pile 
In Step 3, you will create a bored pile and specify its cross-section and 

concrete grade. 

1. Right-click on the Stockyard and selected Concretes from the op-

up menu that appears. Then Ctrl-click on the concrete grade 

C35/45. 

2. In the Property Inspector, change the 

Young’s modulus (E) of the new 

concrete to 19.5 GPa and its Name to 

Fleming’s concrete. 

3. Open the Structural Elements group 

in the Stockyard and create a Bored 

Pile. 
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4. In the Property Inspector, change the Length of the new pile to 

12.2 m and its Shaft diameter to 775 mm (its Base diameter will 

automatically increase to 775 mm). Finally, select Fleming’s 

concrete in the Material name box. 

[Docs]\Tutorials\Tutorial 2\Step 3.rpx captures everything you’ve done so far. 

Step 4 – create the force 
In Step 4, you will create the force applied to the pile. 

1. Open the Actions group in the 

Stockyard and create a Force. 

2. In the Property Inspector, change the 

Options > Variability flag of the new 

force to Permanent.  

3. Change Fz (under Components of 

action) to 2000 kN, whereupon the 

Resultant will automatically change 

to 2000 kN.  

[Docs]\Tutorials\Tutorial 2\Step 4.rpx captures 

everything you’ve done so far. 

Step 5 – sleeve the pile 
In Step 5, you will sleeve the pile through the made ground. 

1. Open the Algorithms group in the Stockyard and create a No 

contact algorithm. 

2. In the Property Inspector, change the 

Name of the new algorithm to 

Length in made ground and 

its Custom depth to 1.4 m. The 

Algorithm Option will automatically 

change to Custom depth. In the 

example calculation, the No contact 

depth will also change to 1.4 m 
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(which is depth of ground that the calculation will ignore when 

calculating shaft friction). 

[Docs]\Tutorials\Tutorial 2\Step 5.rpx captures everything you’ve done so far. 

Step 6 – create the scenario and calculation 
In Step 6, you will create the scenario and calculation and link various items 

together. 

1. Open the Common group in the Stockyard and create a 

Situation. 

2. In the Property Inspector, change the 

scenario’s Duration to Transient 

(if not already set). Then, tick the 

following items so that they appear in 

this scenario (as you do so, they will 

appear on the Drawing Board):  

• Wembley borehole 

• Pile 1 

• Horizontal ground 

• Force 1 

3. Open the Calculations group in the Stockyard and create a 

Fleming’s Analysis. 

4. In the Property Inspector, set the Scenario to Situation 1 

and the No contact algorithm to Length in made ground. 

5. Enter the following values for the calculation’s other properties: 

Ultimate shaft load (Us) = 1994 kN; Ultimate base load (Ub) = 

1002 kN; Base stiffness (Eb) = 33.125 MPa; Shaft flexibility (Ms) 

= 0.17%; and Effective column length (Ke) = 45%. These values 

are taken directly from Fleming’s paper. 

6. Finally, set the Maximum settlement ratio to 1%. This controls 

how much of the load vs displacement curve is generated. You 
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want to go up to about 8 mm displacement, which is 1% of the 

pile diameter. 

[Docs]\Tutorials\Tutorial 2\Step 6.rpx captures everything you’ve done so far. 

Step 7 – perform and review the calculation 
In Step 7, you will perform the calculation and produce a report showing the 

relationship between load and displacement. 

1. Run the calculation by 

selecting the Build tab on 

Repute’s ribbon and then 

clicking on the button 

labelled Run 

Calculation 1. 

2. Repute performs the calculation and then changes to its 

Checking Desktop (which displays the Workbook and Graph 

Paper). 

3. Your screen will now look something like this: 

 

4. The Graph Paper displays a graph which is near-identical to 

Figure 6 in Fleming’s paper, showing: 

• base load vs displacement (in blue) 
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• shaft load vs displacement (in pink) 

• total load vs displacement (in green) 

5. You can view the data on which this graph is based in the 

Workbook (left). 

Step 8 – close the project 
In Step 8, you will close and – optionally – save the project. (Note: this is not 

available in the Trial Edition.) 

1. Close the project by clicking on the File menu’s Close command. 

2. If you have made changes to the project since it was last saved, 

Repute will ask you if you want to save before proceeding. 

Answer Yes or No by clicking the appropriate button. 

3. Repute will then (if requested) save and close the project. 

You will find a copy of the project in its final form here: 
 

[Docs]\Tutorials\Tutorial 2\Tutorial 2.rpx 
 

What next? 
Tutorial 3 shows you how to design a single pile in accordance with the 

requirements of Eurocode 7. 
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Tutorial 3. Single pile design to Eurocode 7 
Introduction 
Tutorial 3 shows you how to design a single pile according to the 

requirements of Eurocode 7. The worked example is taken from Chapter 13 

of the book Decoding Eurocode 7 by Bond and Harris (2008), London: Taylor 

and Francis. 

• Ground conditions comprise 8 m of medium strength sandy CLAY 

overlying medium dense gravelly SAND. The clay has a representative 

undrained strength of 45 kPa and a representative weight density of 

18.5 kN/m3. The sand has a representative peak internal friction 

angle of 36, zero effective cohesion, and representative weight 

density of 20 kN/m3. The sand’s constant-volume angle of shearing-

resistance is 33. 

• Groundwater at the site is at 1 m depth and skin friction above 

groundwater will be ignored. 

• The pile studied is a 10 m long, 400 mm square pile made of concrete 

with characteristic weight density of 25 kN/m3. 

• Vertical loads of 650 kN (permanent) and 250 kN (variable) will be 

applied to the pile. 

• You want to determine the minimum pile length required by 

Eurocode 7 according to the National Annexes published in Ireland 

and in the United Kingdom. 

Full hand calculations for this example are given as Examples 13.1 and 13.2 in 
Bond and Harris (2008). 
 
This tutorial is written for users of the Standard, Enterprise, and Trial Editions 
of Repute only. Users of the Professional Edition should look at Tutorials 4-6. 
 

Overview 

• In Step 1, you will use the Project Wizard to enter project 

information, select design standards, and create a scenario to 

represent short-term conditions. 
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• In Step 2, you will use the Borehole Wizard to create a borehole 

containing the clay and sand layers. 

• In Step 3, you will add a water table to the scenario. 

• In Step 4, you will create a pile and specify its cross-section and 

concrete grade. 

• In Step 5, you will use the Action Wizard to create the forces applied 

to the pile. 

• In Step 6, you will use the Calculation Wizard to create a calculation 

and specify the design standard to use in that calculation. 

• In Step 7, you will specify precise details of how you want the 

calculation to be performed. 

• In Step 8, you will perform the calculations and review the results. 

• In Step 9, you will create a second calculation, identical to the first 

but based on the UK National Annex to Eurocode 7. 

• In Step 10, you will close (and optionally save) the project. 

If Repute is not already running, open the program by pressing the Windows 

key, typing Repute 2.5 in the search bar, and clicking on the Repute 

2.5 item that should appear. Once the splash screen has disappeared, 

Repute displays its Welcome screen. 

If you have an existing project open, click Close on the program’s File menu. 

(You will be prompted to save your work if you have not already done so.) 

Step 1 – create the project 
In Step 1, you will use the Project Wizard to enter project information, select 

design standards, and create a scenario to represent short-term conditions. 

1. Open the Project Wizard 

by selecting the Wizards 

tab on Repute’s ribbon 

and then clicking on the 

Project Wizard button. 



P a g e  | 36 R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e  
 

2. When the Wizard appears, type Tutorial 3 in the Project 

name box. Choose the folder where you want to save this project 

by using the Path control – for example, choose Desktop if you 

want to save the project on Windows’ Desktop. 

3. Enter Single pile design to Eurocode 7 in the 

Description box and 03 in the Project ID box. 

4. Click Next to display page 2 of the Wizard. The design standards 

that appear here depend on which edition of Repute you are 

running (the Enterprise Edition supports more design standards 

than the Standard and Professional editions). 

5. Select BS EN 1997-1:2004 and IS EN 1997-1:2005 by 

clicking on the relevant check boxes (a tick mark appears next to 

a standard when it is selected). 

6. Click Next to display page 3. Keep the Number of scenarios as 1 

but change the Design Situation of Scenario 1 to Transient. 
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7. Click Next to display the final page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

8. Click Finish to generate the project. The Project Wizard then: 

• creates Site 1, Ground Surface 1, Design 

Standard 1 and Design Standard 2, and 
Situation 1 

• adds Ground Surface 1 to Situation 1 

• creates a new project named Tutorial 3.rpx containing 

all these items 

9. Finally, rename the design standards to make it easier to identify 

them later, as follows. In the Project Manager, right-click on 

Design Standard 1 (under Design Standards > Limit State 

Standards) and select Properties …. The Property Inspector will 

appear. Change the Name of this standard to EC7 with UK 

NA. 

10. Repeat the previous step for Design Standard 2, renaming 

it EC7 with Irish NA. 

[Docs]\Tutorials\Tutorial 3\Step 1.rpx captures everything you’ve done so far. 

Step 2 – create the borehole 
In Step 2, you will use the Borehole Wizard to create a borehole containing 

the clay and sand layers. 
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1. Open the Borehole 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and clicking on 

the Borehole Wizard 

button. 

2. When the Wizard appears, set the number of layers to 2. 

3. Click Next to display page 2 of the Wizard. Change Layer 1's 

Ground type to Clay, it Thickness to 8 m, and its Weight 

density to 18.5 kN/m3. Leave Layer 2’s Ground type as Sand and 

its Weight density as 20 kN/m3
 but change its Thickness to 5 m. 

4. Click Next to display page 3. Leave the clay’s properties 

unchanged but change the sand’s Internal friction to 35°. Leave 

its Cohesion at 0 kPa and leave the At Critical State? box 

unticked. 

5. Click Next to display page 4. The sand does not appear on this 

page since – as a fine soil – it does not have undrained strength. 

Change the Undrained Strength (top) and Undrained Strength 

(bottom) of the clay to 45 kPa.  
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6. Click Next to display page 5. Since the ground profile does not 

include rock, there is nothing to set on this page. 

7. Click Next to display page 6. Leave the stiffness properties (i.e. 

Shear Modulus) of both layers unchanged. 

8. Click Next to display page 7. Tick Situation 1 to add the new 

borehole to that scenario. 

9. Click Next to display the final page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page.  

10. Click Finish to generate the borehole. The Borehole Wizard then: 

• creates Soil 1 and Soil 2, Layer 1 and Layer 2, 

and Borehole 1 

• links Soil 1 to Layer 1 

• links Soil 2 to Layer 2 

• adds Layer 1 and Layer 2 to Borehole 1 

[Docs]\Tutorials\Tutorial 3\Step 2.rpx captures everything you’ve done so far. 

Step 3 – add a water table 
In Step 3, you will add a water table to the scenario. 

1. Open the Stockyard’s 

Geotechnical 

Constituents panel by 

selecting the Insert tab 

on Repute’s ribbon and 

then clicking on the Geotechnical Constituents button. 

2. Hold the Ctrl key down and click on the item labelled Ground 

Water Table. The newly created water table will appear in 

the Project Manager (under Geotechnical Constituents > Water 

Tables). 
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3. In the Property Inspector (under Location > Relative Position), 

change the Depth of Water Table 1 to 1 m. 

4. In the Project Manager, select Situation 1 (under Scenarios 

> Situations). 

5. In the Property Inspector, place a tick next to Water Table 1 

(under Geotechnical Constituents) to add the water table to this 

scenario. The Drawing Board will refresh. 

6. In this step, you have: 

• created Water Table 1 

• added Water Table 1 to Situation 1 

[Docs]\Tutorials\Tutorial 3\Step 3.rpx captures everything you’ve done so far. 

Step 4 – create the pile 
In Step 4, you will create a pile and specify its cross-section and concrete 

grade. 

1. Display 

Repute’s 

Construct 

desktop by 

selecting the View tab and clicking on the Construct button. The 

program will display the Drawing Board, Project Manager, and 

Stockyard.  

2. Right-click anywhere inside the Stockyard to display its context 

menu and select the Concretes command. The Concretes group 

will open. 

3. Create the concrete by holding the Ctrl key down and clicking 

on C30/37. (When the Ctrl key is pressed, Repute 

automatically creates an instance of the item that is selected in 

the Stockyard.) The newly created concrete will appear in the 

Project Manager (under Materials > Concretes). 

4. Next, click on the Stockyard’s Structural Elements caption (near 

the bottom of the Stockyard). The Structural Elements group will 

open. 
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5. Create the pile by holding the Ctrl key down and clicking on 

Square Pile. The newly created pile will appear in the 

Project Manager (under Structural Elements > Piles). 

6. In the Project Manager, right-click on Pile 1 and select 

Properties .... The Property Inspector will appear. 

7. In the Property Inspector, change the 

Material name (under Material 

Properties) from Not specified 

to Concrete 1. Then change the 

pile’s Length (under Dimensions) to 

10 m and its Breadth (under Section 

Properties) to 400 mm. Leave all 

other properties of the pile 

unchanged. 

8. Returning to the Project Manager, 

select Situation 1 (under Scenarios > Situation). 

9. In the Property Inspector, place a tick next to Pile 1 (under 

Structural Elements) to add the pile to this scenario. The Drawing 

Board will refresh. 

10. In this step, you have: 

• created Concrete 1 and Pile 1 

• linked Concrete 1 to Pile 1 

• added Pile 1 to Situation 1 

[Docs]\Tutorials\Tutorial 3\Step 4.rpx captures everything you’ve done so far. 

Step 5 – create the forces 
In Step 5, you will use the Action Wizard to create the forces applied to the 

pile. 

1. Open the Action Wizard 

by selecting the Wizards 

tab on Repute’s ribbon 
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and clicking on the Action Wizard button. 

2. When the Wizard appears, increase the No. of forces to 2; 

Force 1 and Force 2 will be created. 

3. Set the Fz value for Force 1 to 650 kN and change its 

Variability to Permanent. Then set the Fz value for Force 2 

to 250 kN but keep its Variability as Variable. Leave all other 

properties unchanged (at zero). 

4. Click Next to display page 2 of the Wizard. Since no moments are 

applied to the pile, leave the No. of moments as 0. 

5. Click Next to display page 3. Increase the No. of combinations to 

1; Combination 1 will be created. Click on the label None 

selected under the column Forces to include and then tick 

Force 1 and Force 2. 

6. Click Next to display the last page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page.  

7. Click Finish to generate the actions and their combination. The 

Actions Wizard will then: 

• create Force 1 and Force 2 

• create Combination 1 

• add Force 1 and Force 2 to Combination 1 

8. Returning to the Project Manager, select Situation 1 (under 

Scenarios > Situations). 
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9. Then, in the Property Inspector, place a tick next to 

Combination 1 (under Actions) to add the combination to 

this scenario. The Drawing Board will refresh. 

[Docs]\Tutorials\Tutorial 3\Step 5.rpx captures everything you’ve done so far. 

Step 6 – create the calculation 
In Step 6, you will use the Calculation Wizard to create a calculation and 

specify the design standard to use in that calculation. 

1. Open the Calculation 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and then clicking 

on the Calculation 

Wizard button. 

2. When the Wizard appears, tick Longitudinal ULS. (The 

calculations that appear here depend on which edition of Repute 

you are running. The Enterprise Edition provides more 

calculations than the Standard and Professional editions.) 

3. Click Next to display page 2 of the Wizard. Select EC7 with 

Irish NA. 
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4. Click Next to display page 3. Tick Situation 1. 

5. Click Next to display the final page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

6. When you are ready, click Finish to generate the first calculation. 

The Calculation Wizard then: 

• creates Calculation 1 

• links Situation 1 to Calculation 1 

• links EC7 with Irish NA to Calculation 1  

[Docs]\Tutorials\Tutorial 3\Step 6.rpx captures everything you’ve done so far. 

Step 7 – customize the calculation 
In Step 7, you will specify precise details of how the calculation is to be 

performed, following the decisions made by Bond and Harris, 2008. 

1. Open the 

Stockyard’s 

Algorithms 

group by 

selecting the 

Insert tab on Repute’s ribbon and then clicking on the Algorithm 

button. 

2. Hold the CTRL key down and click on No contact 

algorithm in the Stockyard. Then, in the Property Inspector, 
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change the Name of the new algorithm to No skin 

friction and enter Ignore skin friction above 

water table in its Notes field. Enter a value of 1.0 m into the 

Custom depth box, whereupon Algorithm > Option will 

automatically change to Custom depth.  

3. Hold the CTRL key down 

and click on Alpha in 

the Stockyard. Change 

the Name of the new 

algorithm to Alpha in 

clay and enter From 
US Army Corps of 

Engineers in its Notes 

field. Enter a value of 0.8 into the Custom alpha box, whereupon 

Algorithm > Option will automatically change to Custom 

alpha. 

4. Hold the CTRL key down and click on Earth pressure 

coefficient in the Stockyard. Change the Name of the new 

algorithm to Ks in sand and enter Nq/50 in its Notes field. 

Enter a value of 1.59 into the Custom compression coefficient 

box, whereupon Algorithm > Option will automatically change to 

Custom earth pressure coefficient. 

5. Hold the CTRL key down and click on Wall friction in the 

Stockyard. Change the Name of the new algorithm to Delta 

in sand and enter critical state friction angle 

in its Notes field. Enter a value of 33 into the Custom friction 

value box, whereupon Algorithm > Option will automatically 

change to Custom friction value. 

6. Hold the CTRL key down and click on Bearing capacity 

algorithm in the Stockyard. Change the Name of the new 

algorithm to Nq in sand. Change the Option to 

Berezantzev. In the Example Calculation group, change the 
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Angle of shearing resistance to 35 and the Slenderness ratio to 

25. The value of Nq will update (to 47.23), while Nc remains Not 

specified (Berezantzev’s algorithm is only applicable to 

sands, hence Nc is not available). 

7. In the Project Manager (under Calculations > Single Pile 

Calculations), select Calculation 1. 

8. In the Property Inspector, link the calculation to the algorithms 

you have just created by selecting the appropriate items in the 

drop-down boxes next to the following headings. 

9. Under Algorithms: 

• No contact algorithm – select No 
skin friction 

10. Under Soils: 

• Undrained adhesion – select 
Alpha in clay 

• Earth pressure coefficient – 

select Ks in sand 

• Wall friction (delta/phi) – select 
Delta in sand 

• Bearing capacity in soil – select 
Nq in sand  

11. Finally, set the Drainage condition to 

Undrained to tell the program to 

base the calculation in clay on total 

stresses. 

[Docs]\Tutorials\Tutorial 3\Step 7.rpx captures everything you’ve done so far. 

Step 8 – perform and review the calculations 
In Step 8, you will perform the calculation and review the results. 

1. Run the calculation by 

selecting the Build tab on 

Repute’s ribbon and then 
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clicking on the Run Calculation 1 button. 

2. Repute will perform the specified calculation and then change to 

its Check Desktop (which displays the Workbook and Graph 

Paper). Your screen will now look something like this: 

 

3. The Graph Paper (middle panel) shows the: 

• effect of actions (E, equal to the sum of the applied forces 

and the self-weight of the pile) increasing with depth 

• separate components of tensile resistance (Rt), base 

resistance (Rb), and shaft resistance (Rs) also increasing with 

depth 

• the total compressive resistance (Rc = Rs + Rb) exceeding the 

effect of actions (Rc > E) at a depth between 11 and 12 m 

4. The Workbook (left panel) shows the same information in 

tabular format. The Workbook contains a lot more information 

than is initially shown. To display this additional information, click 

on the button in the top-left-hand corner (labelled *) and select 

the data you want to see. The picture here shows results for the 

depth 10 m. 
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5. The results calculated by Repute differ from those given in the 

book by Bond and Harris (2008), where a model factor on 

resistance of 1.5 was used (following the draft Irish National 

Annex). Instead, Repute uses the value 1.75 that appears in the 

published version of that Annex. 

6. You can check this by selecting the 

View tab on Repute’s ribbon and then 

clicking on the Specify button. Then, 

select EC7 with Irish NA in the 

Project Manager to display its 

properties in the Property Inspector – 

the value given for Options > Model 

factor on resistance is 1.75. 

A Repute project that reproduces Bond and Harris’s results can be found 

here: 

[Docs]\Examples\Bond and Harris (2008) Ex 13.1.rpx. 

Step 9 – change the design standard 
In Step 9, you will create a second calculation, identical to the first but based 

on the UK National Annex to Eurocode 7. 

1. Returning to the Project Manager, create a copy of 

Calculation 1 by right-clicking on it (look under Calculations 
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> Single Pile Calculations) and selecting the Edit > Duplicate 

command. 

2. In the Property 

Inspector, change the 

Name of the newly 

created calculation to UK 

calculation and its 

Design Standard to EC7 

with UK NA. 

3. In the Project Manager, 

select the Design 

Standard EC7 with 

UK NA (under Design Standards > Limit State Standards). 

4. Then in the Property Inspector, set Options > Pile testing to 

Investigation tests. The values of the model factor and 

the resistance factors will change. This setting is appropriate 

when the calculated resistance will be checked by static pile load 

tests taken to ultimate load. 
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5. In the Project Manager, select the UK calculation (under 

Calculations > Singler Pile Calculations) and then run the 

calculation by selecting the Build tab on Repute’s ribbon and 

clicking on the Run UK calculation button. Your screen 

will now look something like this: 

 

[Docs]\Tutorials\Tutorial 3\Step 9.rpx captures everything you’ve done so far. 

Step 10 – close the project 
In Step 10, you will close and – optionally – save the project. (Note: this is not 

available in the Trial Edition.) 

1. Close the project by clicking on the File menu’s Close command. 

2. If you have made changes to the project since it was last saved, 

Repute will ask you if you want to save before proceeding. 

Answer Yes or No by clicking the appropriate button. 

3. Repute will then (if requested) save and close the project. 

 
You will find a copy of the project in its final form here: 
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[Docs]\Tutorials\Tutorial 3\Tutorial 3.rpx 

 

What next? 
Tutorial 4 shows how the boundary element method can be used to analyse a 

pile group.  
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Tutorial 4. Pile group in clay and sand 
Introduction 
Tutorial 4 demonstrates how the boundary element method can be used to 

analyse a pile group. The worked example involves a group of four bored 

piles in stiff clay overlying dense sand: 

• Ground conditions comprise 8m of stiff clay overlying dense sand. 

Both soils will be modelled as linear elastic materials.  

• The stiff clay has a vertical Young’s modulus of 40 MPa and a 

horizontal modulus of 20 MPa, with Poisson’s ratio equal to 0.5. 

• The dense sand has the same Young’s modulus vertically and 

horizontally, equal to 50 + 10 z MPa (where z is the depth below the 

top of the sand in metres), and Poisson’s ratio equal to 0.3. 

• The bored piles are installed on a 2 x 2 grid, at 3 m spacing (centre-

to-centre). Each pile is 20 m long, 1050 mm in diameter, with a 

Young’s modulus (vertically and horizontally) of 30 GPa. 

• A characteristic vertical force of 12 MN (permanent), horizontal force 

of 1 MN (variable), and moment of 2 MNm (variable) are applied at 

the centre of the pile group. 

• You want to determine the displacement and rotation of the pile cap 

under serviceability conditions. 

This tutorial is written for users of the Professional, Enterprise, and Trial 

Editions of Repute only. Users of the Standard Edition should look at Tutorials 

1-3. 

Overview 

• In Step 1, you will use the Project Wizard to enter project information 

and create a scenario to represent a persistent design situation. 

• In Step 2, you will use the Pile Group Wizard to create a 2 x 2 pile 

group and specify the piles’ properties. 

• In Step 3, you will use the Borehole Wizard to create a borehole 

containing stiff clay and dense sand layers. 

• In Step 4, you will enter the stiffness parameters for Soils 1 and 2. 
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• In Step 5, you will use the Action Wizard to create the actions applied 

to the pile group. 

• In Step 6, you will use the Calculation Wizard to create the 

calculation you want Repute to perform. 

• In Step 7, you will perform the calculation and review the results. 

• In Step 8, you will produce a report summarising the calculation. 

• In Step 9, you will close and (optionally) save the project. 

If Repute is not already running, open the program by pressing the Windows 

key, typing Repute 2.5 in the search bar, and clicking on the Repute 

2.5 item that should appear. Once the splash screen has disappeared, 

Repute displays its Welcome screen. 

If you have an existing project open, click Close on the program’s File menu. 

(You will be prompted to save your work if you have not already done so.) 

Step 1 – create the project 
In Step 1, you will use the Project Wizard to enter project information and 

create a scenario to represent the design situation to be analysed. 

1. Open the Project Wizard 

by selecting the Wizards 

tab on Repute’s ribbon 

and then clicking on the 

Project Wizard button. 

2. When the Wizard appears, type Tutorial 4 in the Project 

name box. Choose the folder where you want to save this project 

by using the Path control. If you do not change the setting here, 

the file will be saved in your Documents folder. 

3. Enter Pile group in clay and sand in the Description 

box and 04 in the Project ID box. 

4. Click Next to display page 2 of the Wizard. Since we are not going 

to use a design standard, there is nothing to set on this page. 



P a g e  | 54 R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e  
 

5. Click Next to display page 3. In the table, change the Design 

Situation of Situation 1 to Persistent (if it is not already set). 

6. Click Next to display the final page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

7. When you are ready, click Finish to generate the project. The 

Project Wizard then: 

• creates Site 1, Ground Surface 1, and Situation 
1 

• adds Ground Surface 1 to Situation 1 

• creates a new project Tutorial 4.rpx containing all 

these items  

[Docs]\Tutorials\Tutorial 4\Step 1.rpx captures everything you’ve done so far. 

Step 2 – create the pile group 
In Step 2, you will use the Pile Group Wizard to create a 2 x 2 pile group and 

specify the piles’ properties. 

1. Open the Pile Group 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and clicking on 

the Pile Group Wizard button. 

2. When the Wizard appears, choose the 

Predefined plan arrangement and change the 

Total number of piles to 4. The picture on the left-

hand side of the Wizard will change to show you 

the default 2 x 2 pile arrangement. Change the 

Spacing between the piles to 3000 mm but leave the Cover at its 

default value (150 mm). 



R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e    P a g e  | 55 
 

 

3. Click Next to display page 2 of the Wizard. If not already set, set 

the pile type to (Cast-in-place Concrete) Bored 

Pile. 

4. Click Next to display page 3. Change the Concrete class to 

C20/25 and the Diameter/Breadth to 1050 mm. By default, 

this concrete’s Young’s modulus will be set to 30 GPa (not 

shown). 

5. Click Next to display page 4. Change the Embedded length (L) to 

20 m but leave the Upstand (U) as 0 m. 
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6. Click Next to display page 5. Leave all the values on this page as 

zero – this will position the pile group centrally in the co-ordinate 

system (and not rotated). 

7. Click Next to display page 6. Tick Situation 1 to add the pile 

group to the scenario. 

8. Click Next to display the last page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page.  



R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e    P a g e  | 57 
 

 

9. When you are ready, click Finish to 

generate the pile group. The Pile 

Group Wizard then: 

• creates Piles 1 to 4 

• creates Pile Group 1 

• creates Concrete 1 

• links Piles 1 to 4 to 
Concrete 1 

• adds Piles 1 to 4 to Pile 
Group 1 

• adds Pile Group 1 to 
Situation 1 

10. In the Property Inspector, set the Pile 

Cap > Pile cap thickness to 1.5 m 

and press ENTER. 

[Docs]\Tutorials\Tutorial 4\Step 2.rpx captures everything you’ve done so far. 

Step 3 – create the borehole 
In Step 3, you will use the Borehole Wizard to create a borehole containing 

stiff clay and dense sand layers. 

1. Open the Borehole 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and clicking on 

the Borehole Wizard button. 

2. When the Wizard appears, increase the number of layers to 2. 

3. Click Next to display page 2 of the Wizard. Change the Ground 

type of Layer 1 to Clay, its Thickness to 8 m, and its Weight 

density to 18 kN/m3. Leave the Ground type of Layer 2 as 

Sand but change its Thickness to 20 m and its Weight density to 

21.5 kN/m3. 
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4. Click Next to display page 3. Change the Internal friction angle of 

Layer 1 to 25 and that of Layer 2 to 36. Leave the 

Cohesion of both soils as 0 kPa and the At Critical State? boxes 

unchecked. 

5. Click Next to display page 4. Change the Undrained strength 

(top) of Layer 1 to 100 kPa and its Undrained strength 

(bottom) to 600 kPa. This strength increase will occur over the 

full thickness of Layer 1, i.e. 8 m (as specified above). Layer 

2 does not appear on this page because – as a sand – it has no 

undrained properties. 

6. Click Next to display page 5. Since the ground profile does not 

include rock, there is nothing to set on this page. 

7. Click Next to display page 6. For Layer 1, to obtain a large-

strain undrained Young’s modulus Eu = 40 MPa, enter its Shear 

modulus G1 as 13.33 MPa, which is equal to Eu/2(1 + u) = Eu/3, 

with a Poisson’s ratio u = 0.5. Leave its Shear Modulus G0 value 

as 100 MPa. 

8. For Layer 2, to obtain a large-strain drained Young’s modulus 

E = 50 MPa, enter its Shear modulus G1 as 19.23 MPa – which 

is equal to E/2(1 + ) = E/2.6, with a Poisson’s ratio  = 0.3. 

Leave its Shear Modulus G0 value as 100 MPa. 
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9. Click Next to display page 7. Tick Situation 1 to add the 

borehole to the scenario. 

10. Click Next to display the last page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

11. When you are ready, click Finish to generate the borehole. The 

Borehole Wizard then: 

• creates Soils 1-2 

• creates Layers 1-2 

• creates Borehole 1 

• links Soil 1 to Layer 1 

• links Soil 2 to Layer 2 

• adds Layers 1-2 to Borehole 1 

• adds Borehole 1 to Situation 1 

[Docs]\Tutorials\Tutorial 4\Step 3.rpx captures everything you’ve done so far. 

Step 4 – modify the soils’ stiffness properties 
In Step 4, you will modify the stiffness properties of Soils 1 and 2. 

1. Select Soil 1 in the Project Manager (under Materials > Soils).  

2. In the Property Inspector, change the value of Stiffness > 

Undrained Young’s modulus (Eu) > Large strain stiffness > 

Undrained Young’s modulus (Eu) to 40 MPa (from 39.99 MPa).   

3. The Stiffness ratio G1/G0 is shown as 13.33%, which is obtained 

by dividing the Small strain stiffness > Shear modulus (G) value 

of 100 MPa (= G0) by Large strain stiffness > Shear modulus (G) 

value of 13.33 MPa (= G1). Look under the heading Stiffness > 

Shear modulus (G) for these values. 
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4. Type 0.5 in the Stiffness > Anisotropy box to change the Large 

strain stiffness > Horizontal Young’s modulus (Eh) value to 20 

MPa (i.e. 40 MPa x 0.5). 

5. Back in the Project Manager, select Soil 2. The Property 

Inspector will change to display its properties.  

6. Under the heading Depth, check that Reference depth 1 (z,ref1) 

is equal to 8 m (this is the top of the soil layer) and Reference 

depth 2 (z,ref2) is equal to 28 m (this is the bottom of the layer). 

7. Under the heading Stiffness, check that the Poisson’s ratio (v) of 

this soil is equal to 0.3. 

8. Under the heading Young’s modulus (E) > Large-strain stiffness, 

expand the heading Variation with depth by clicking on the + 

button. Enter 250 MPa into the E’,ref2 box. The value of Young’s 

modulus gradient (dE/dz) will change to 10 MN/m3 – equal to 

(E,ref1 – E,ref2) / (z,ref1 – z,ref2) = (250 MPa – 50 MPa)/(28 m  

– 8 m). 

[Docs]\Tutorials\Tutorial 4\Step 4.rpx captures everything you’ve done so far. 

Step 5 – create the forces and moments 
In Step 5, you will use the Action Wizard to create loads applied to the pile 

group. 

1. Open the Action Wizard 

by selecting the Wizards 

tab on Repute’s ribbon 

and clicking on the 

Action Wizard button. 

2. When the Wizard appears, increase the No. of forces to 2. Set 

the Fz value of Force 1 to 12000 kN, its Variability to 

Permanent, and its Depth to –1.5 m. Set the Fx value of Force 

2 to 1000 kN, its Fz value to 0 kN, and its Depth to –1.5 m but 

leave its Variability as Variable. 
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3. Click Next to display page 2 of the Wizard. Increase the No. of 

moments to 1. Set the My value of Moment 1 to 500 kNm and 

its Depth to –1.5 m but leave its Variability as Variable. 

4. Click Next to display page 3. Increase the No. of combinations to 

1. Under the column Forces to include, click the text None 

selected and then tick Force 1 and Force 2. Click away. 

Then, under the column Moments to include, click the text None 

selected and then tick Moment 1. Click away. 

5.  Click Next to display the last page.  If you wish to review any of 

the settings you have made, click Back to return to the relevant 

page. 

6. When you are ready, click Finish to generate the actions and their 

combination. The Actions Wizard then: 

• creates Forces 1 and 2 

• creates Moment 1 

• creates Combination 1 

• adds Forces 1 and 2 and Moment 1 to 
Combination 1 
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7. Going back to the Project Manager, select Situation 1 

(under Scenarios > Situations). 

8. Then, in the Property Inspector, tick Combination 1 (under 

Actions) to add the combination to this scenario. The Drawing 

Board will automatically update. 

[Docs]\Tutorials\Tutorial 4\Step 5.rpx captures everything you’ve done so far. 

Step 6 – create the calculation 
In Step 6, you will use the Calculation Wizard to create the calculation you 

want Repute to perform. 

1. Open the Calculation 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and then clicking 

the Calculation Wizard button. 

2. When the Wizard appears, select Boundary Element 

Analysis. (The calculations that appear here depend on which 

edition of Repute you are running. The Enterprise Edition 

provides more calculations than the Standard and Professional 

editions.) 

3. Click Next to display page 2 of the Wizard. Since there are no 

design standards to select from, there is nothing to do on this 

page. 

4. Click Next to display page 3. Select Situation 1 to link the 

boundary element analysis to that scenario. 
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5. Click Next to display the last page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

6. When you are ready, click Finish to generate the calculation. The 

Calculation Wizard then:  

• creates Calculation 1 

• links Calculation 1 to Situation 1 

7. In the Property Inspector, for 

Calculation 1, change the 

Stress-strain model (under Options) 

to Linear-elastic. The strength 

of the soils is irrelevant in a linear-

elastic analysis and hence it does not 

matter whether the Drainage 

condition is set to Drained or 

Undrained. 

[Docs]\Tutorials\Tutorial 4\Step 6.rpx captures everything you’ve done so far. 

Step 7 – perform and review the calculation 
In Step 7, you will perform the calculation and review the results. 

1. Run the calculation by 

selecting the Build tab on 

Repute’s ribbon and 

clicking on the Run 
Calculation 1 

button. 

2. Repute will run Calculation 1 and then change its display to 

show its Checking Desktop (which displays the Workbook and 

Graph Paper). You can switch to this display at any time by 

clicking on the Check button on the View tab of Repute’s ribbon. 

3. Your screen will now look something like this: 
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4. To display the force distribution along the piles, select Axial force 

Fz in the drop-down box labelled Pile Group on the Graph Paper 

tab. The graph will change to display: 
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Step 8 – close the project 
In Step 8, you will close and – optionally – save the project. (Note: this is not 

available in the Trial Edition.) 

1. Close the project by clicking on the File menu’s Close command. 

2. If you have made changes to the project since it was last saved, 

Repute will ask you if you want to save before proceeding. 

Answer Yes or No by clicking the appropriate button. 

3. Repute will then (if requested) save and close the project. 

 
You will find a copy of the project in its final form here: 

 
[Docs]\Tutorials\Tutorial 4\Tutorial 4.rpx 

 

What next? 
Tutorial 5 shows you how to set up a non-linear boundary element analysis of 

a pile group in stiff clay overlying rock. 
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Tutorial 5. Pile group in stiff clay over a rigid layer 
Introduction 
This tutorial demonstrates non-linear boundary element analysis of a pile 

group. It shows you how to: 

• Specify a non-linear analysis 

• Introduce a rigid layer into the calculations 

• Produce a load displacement graph for the pile cap 

• Print the results of your calculations 

The worked example involves the analysis of a group of 4 piles installed in 
stiff clay overlying a rigid layer. 
 

• The ground conditions at the site comprise 35 m of stiff clay (Young's 
modulus 75 + 10 z MPa vertically and half that horizontally, where z is 
the depth below the top of the layer; Poisson's ratio 0.5) overlying a 
rigid layer. 

• A non-linear soil model will be used for the clay, with unit weight 
19.8 kN/m3, undrained strength 75 + 10 z kPa, and adhesion factor 
0.5. 

• The water table is at the ground surface. 

• The piles will be installed on a 2 x 2 grid, at 3 m spacing (centre-to- 
centre) along the edge of the grid. Each pile is 20 m long, 1.05 m in 
diameter, with a free-standing length of 0.5 m and Young's modulus 
of 30 GPa (both axially and laterally). This is the same pile group as 
was used in Step 2 of Tutorial 4. 

• You are interested in the displacements and rotation of the pile cap 
under a combined vertical load of 20 MN, horizontal load of 2 MN, 
and moment of 3 MNm. The loads will be applied at the centre of the 
pile cap. 

• Hyperbolic curve fitting constants of 0.5 (for the shaft), 0.99 (for the 
base), and 0.9 (for lateral response) should be used. 

 
This tutorial is written for users of the Professional, Enterprise, and Trial 
Editions of Repute only. Users of the Standard Edition should look at Tutorials 
1-3. 
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Overview 

• In Step 1, you will use the Project Wizard to enter project information 

and create a scenario to represent the design situation to be 

analysed. 

• In Step 2, you will create four piles and connect them together in a 

pile group. 

• In Step 3, you will create a stiff clay and specify its properties. 

• In Step 4, you will create a layer, borehole, and water table. 

• In Step 5, you will create a force, moment, and combination of 

actions (to combine the force and moment). 

• In Step 6, you will create the calculation that you want Repute to 

perform. 

• In Step 7, you will perform the calculation. 

• In Step 8, you will export results to a Microsoft Excel spreadsheet. 

• In Step 9, you will close and (optionally) save the project. 

If Repute is not already running, open the program by pressing the Windows 

key, typing Repute 2.5 in the search bar, and clicking on the Repute 

2.5 item that should appear. Once the splash screen has disappeared, 

Repute displays its Welcome screen. 

If you have an existing project open, click Close on the program’s File menu. 

(You will be prompted to save your work if you have not already done so.) 

Step 1 – create the project 
In Step 1, you will use the Project Wizard to enter project information and 

create a scenario to represent the design situation to be analysed. 

1. Open the Project Wizard 

by selecting the Wizards 

tab on Repute’s ribbon 

and then clicking on the 

Project Wizard button. 
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2. When the Wizard appears, type Tutorial 5 in the Project 

name box. Choose the folder where you want to save this project 

by using the Path control. (If you do not change the setting here, 

it will be saved in your Documents folder.) Enter Pile group 

in stiff clay over a rigid layer in the 

Description box and 05 in the Project ID box. 

3. Click Next to display page 2 of the Wizard. Since we are not going 

to use a design standard, there is nothing to set on this page. 

4. Click Next to display page 3. Since the Design Situation of 

Situation 1 is already set to Persistent, there is nothing 

to change on this page. 

5. Click Next to display the final page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

6.  Click Finish to generate the project. 

The Project Wizard then: 

• creates Site 1, Ground 

Surface 1, and Situation 
1 

• adds Site 1 and Ground 

Surface 1 to Situation 1 

• creates a new project with 

Tutorial 5.rpx with all 

these items in it 

[Docs]\Tutorials\Tutorial 5\Step 1.rpx captures everything you’ve done so far. 

Step 2 – create the pile group 
In Step 2, you will create four piles and connect them together in a pile 

group. 

1. Switch to Repute’s 

Construction Desktop by 

selecting the View tab on 

Repute’s ribbon and 
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clicking on the Construct button. (The Construction Desktop 

displays the Drawing Board, Project Manager, and Stockyard.) 

2. Right-click anywhere in the Stockyard and select Concretes from 

the pop-up menu to open the Concretes group. Then: 

• click on C20/25, keeping the left mouse button pressed 

• drag the cursor away from the Stockyard (whereupon the 

cursor will change to 

signal the dragging 

operation) and 

position it over the 

Project Manager 

• release the mouse 

button to drop the 

concrete in the 

Project Manager 

(where it will appear as Concrete 1, under the heading 

Materials > Concretes). 

3. Back in the Stockyard, click on the 

heading Structural Elements to open 

the Structural Elements group. Then 

drag a Bored Pile to the Project 

Manager as described above. 

4. Repeat the previous instruction for a 

Pile Group. 

5. Switch to Repute’s Specification 

Desktop by selecting the View tab on 

Repute’s ribbon and clicking on the 

Specify button. (The Specification 

Desktop displays the Drawing Board, 

Project Manager, and Property 

Inspector.) 
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6. In the Project Manager, select Pile 1 (under Structural 

Elements > Piles). The Property Inspector will change to show its 

properties. 

7. In the Property Inspector: 

• under Location > Relative 

Position, change both the pile’s X-

position and Y-position to 1.5 

m. 

• under Section Properties, tick the 

box Has casing and change the 

pile’s Shaft diameter to 1050 

mm. The pile’s Base diameter will 

change to 1050 mm as well. 

• under Material Properties, select 

Concrete 1 in the Material 

name box. 

• under Dimensions, change the 

pile’s Length to 20 m (if not 

already set) and its Free-standing length to 0.5 m. 

8. Next, duplicate Pile 1 

by right-clicking on it in 

the Project Manager and 

selecting Edit > Duplicate 

on the pop-up menu. 

Pile 1 - Copy will 

appear in the Project 

Manager and its 

properties will be displayed in the Property Inspector. 

9. In the Property Inspector, change the Name of the copied pile to 

Pile 2 and its X-position to –1.5 m. Leave all its other 

properties unchanged. 



R e p u t e  2 . 5  Q u i c k - S t a r t  G u i d e    P a g e  | 71 
 

 

10. Duplicate Pile 2 via the Edit > Duplicate command (as 

described above) or – even quicker – select Pile 2 and then 

press CTRL+D to duplicate it. 

11. In the Property Inspector, change the Name of the copied pile to 

Pile 3 and its Y-position to –1.5 m, keeping its X-position as 

–1.5 m. 

12. Finally, duplicate Pile 3, changing the duplicate’s Name to 

Pile 4 and its X-position to (plus) 1.5 m and keeping its Y-

position as −1.5 m. 

13. Next, select Pile Group 1 in the 

Project Manager and, in the Property 

Inspector:  

• change its Level (under the 

heading Location > Absolute 

Position) to 0.5 m. 

• tick all four piles (under the 

heading Piles) 

• change the Pile cap thickness to 

1.25 m (under the heading Pile 

Cap) and click the Resize button 

to ensure the pile cap’s 

dimensions reflect the piles’ new 

positions 

14. Finally, in the Project Manager, select 

Situation 1 (under Scenarios > 

Situations) and tick Pile Group 1 

in its Property Inspector to add the 

pile group to the scenario. 
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15. The Drawing Board will now look 

something like this (note that the pile 

cap appears in yellow, since we have 

not specified a material to link to this 

element). 

16. In this step you have: 

• created Concrete 1, Pile 1, 

and Pile Group 1 

• linked Pile 1 to Concrete 1 

• duplicated Pile 1 to create 

Piles 2, 3, and 4 and 

changed their locations 

• added Piles 1-4 to Pile 
Group 1 

• added Pile Group 1 to 
Situation 1 

[Docs]\Tutorials\Tutorial 5\Step 2.rpx captures 

everything you’ve done so far. 

Step 3 – create the soil 
In Step 3, you will create a stiff clay and specify its properties. 

1. Open the Stockyard’s 

Grounds group by 

selecting the Insert tab 

on Repute’s ribbon and 

clicking on the Ground 

button. 

2. In the Stockyard: 

• click on Clay while keeping the left mouse button pressed 

• drag the cursor away from the Stockyard over the Project 

Manager (The cursor will change to signal you are dragging) 
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• release the mouse button when the cursor is over the Project 

Manager to drop the clay there (it will appear as Soil 1 

under the heading Materials > Soils) 

3. Double-click on Soil 1 to open its Property Inspector. 

4. In the Property Inspector for Soil 1: 

• if necessary, untick Strict validation (under Classification) 

• change the clay’s Weight density (under Mass/weight 

densities) to 

19.8 kN/m3
 – its 

Mass density will 

change accordingly 

• set Reference depth 

2 (z,ref2) (under 

Depth) to 35 m – 

this is the bottom of 

the soil layer 

• change the clay’s 

Undrained strength 

(under Strength > 

Undrained strength) 

to 75 kPa 

• open the heading 

Undrained strength > 

Variation with depth 

by clicking on the + button to the left of it and set cu,ref2 to 

425 kPa – the Undrained strength gradient (dcu/dz) will 

change to 10 kN/m3 
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5. Continuing in the Property Inspector for Soil 1 – under the 

heading Stiffness > Undrained Young’s modulus > Small strain 

stiffness: 

• set the clay’s 

Undrained Young’s 

modulus (Eu) to 75 
MPa – the Large 

strain stiffness > 

Undrained Young’s 

modulus (Eu) will 

change to 15 MPa, 

since the Stiffness 

ratio G1/G0 – and 

hence Eu1/Eu0 – is (by 

default) set to 20% 

• open the heading 

Variation with depth 

and enter 425 MPa 

as the value of 

Eu,ref2 – the Young’s 

modulus gradient 

(dE/dz) will change to 10 MN/m3 

6. Finally, change the clay’s Anisotropy (under Stiffness) to 0.5 –

the clay’s Small strain stiffness > Horizontal Young’s modulus 

(Eh) changes from 75 MPa to 37.5 MPa 

[Docs]\Tutorials\Tutorial 5\Step 3.rpx captures everything you’ve done so far. 

Step 4 – create a layer, borehole, and water table 
In Step 4, you will create a layer and borehole to hold the stiff clay and a 

water table (at ground surface). 
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1. In the Stockyard, open 

the Geotechnical 

Constituents group and 

then create a Soil Layer, 

a Rigid Layer, a Borehole, 

and a Ground Water 

Table by dragging-and-

dropping these items 

from the Stockyard to 

the Project Manager. 

2. Add Water Table 1 to the scenario by dragging it from the 

Project Manager to the Drawing Board. 

3. Select Layer 1 in the Project Manager and then, in the 

Property Inspector, change its Thickness to 35 m and its Soil to 

Soil 1. 

4. Select Borehole 1 in the Project Manager and, in the 

Property Inspector, press the Select ... button. In the dialog box 

that appears, click on the >> button to move Layer 1 and 

Layer 2 from the Available box to the Selected box. Click OK 

to confirm the changes. 

5. Select Situation 1 in the Project Manager and, in the 

Property Inspector, tick Borehole 1 to add it to the scenario. 
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The borehole column will appear on the left-hand side of the 

Drawing Board. 

6. In this step you have manually: 

• created Layers 1-2, Borehole 1, and Water Table 
1 

• added Water Table 1 to Situation 1 

• linked Soil 1 to Layer 1 

• added Layers 1-2 to Borehole 1 

• added Borehole 1 to Situation 1 

[Docs]\Tutorials\Tutorial 5\Step 4.rpx captures everything you’ve done so far. 

Step 5 – create forces and moments 
In Step 5, you will create a force, moment, and combination of actions (to 

combine the force and moment). 

1. In the Stockyard, open 

the Actions group and 

then create a Force, a 

Moment, and a 

Combination of Actions 

by dragging-and-dropping these items from the Stockyard to the 

Project Manager. 
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2. Select Force 1 in the 

Project Manager and, in 

the Property Inspector, 

change its Level (under 

Location > Absolute 

Position) to 1.75 m – 

the Depth will change to 

–1.75 m as you do this 

(the change in level is 

necessary to place the 

force on top of the pile 

cap). Change the force’s 

Fx value to 2000 kN and 

its Fz value to 20 000 kN 

– the Resultant will 

change to 20 099.75 kN.  

3. Select Moment 1 in the 

Project Manager and, in 

the Property Inspector, 

change its Level to 

1.75 m but leave its My value as 500 kNm. 

4. Select Combination 1 in the Project Manager and, in the 

Property Inspector, tick both Force 1 and Moment 1. Note 

that the My value is shown as 4000 kNm because of the 

additional moment due to Fx (which is at a level of 1.75 m) is 

2000 kN x 1.75 m = 3500 kNm. If you change the Level of 

Combination 1 to 1.75 m, then the My value will revert to 

500 kNm as the lever arm of Fx becomes zero. 

5. Finally, select Situation 1 in the Project Manager and, in the 

Property Inspector, tick Combination 1 to add it to the 

scenario. Arrows representing the applied force and moment will 

appear on the Drawing Board above the pile group. 

6. In this step you have manually: 
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• created Force 1, Moment 1, and Combination 1 

• added Force 1 and Moment 1 to Combination 1 

• added Combination 1 to Situation 1 

[Docs]\Tutorials\Tutorial 5\Step 5.rpx captures everything you’ve done so far. 

Step 6 – create the calculation 
In Step 6, you will create a boundary element analysis of the pile group. 

1. In the Stockyard, open the Calculations group by right-clicking 

and selecting Calculations from the pop-up menu. 

2. Drag-and-drop a Boundary Element Analysis from the Stockyard 

to the Project Manager. 

3. In the Property 

Inspector, change the 

Scenario (under Links) to 

Situation 1. Then, 

change the Drainage 

condition (under 

Options) to Undrained 

and the Stress-strain 

model to Hyperbolic. 

4. In this step you have: 

• created 
Calculation 1 

• linked Situation 1 to Calculation 1 

[Docs]\Tutorials\Tutorial 5\Step 6.rpx captures everything you’ve done so far. 

Step 7 – perform and review the calculation 
In Step 7, you will perform the calculation and review the results. 
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1. Run the calculation by 

selecting the Build tab on 

Repute’s ribbon and then 

clicking on the Run All 

button. 

2. Repute will perform the calculation and then change its display to 

show its Checking Desktop (displaying the Project Manager, 

Workbook, and Graph Paper). You can switch to this display at 

any time by clicking on the Check button on Repute’s View tab.  

3. Your screen will now look something like this: 

Step 8 – export the results 
In Step 8, you will export results to a Microsoft Excel spreadsheet. 

1. Right-click in the Workbook to reveal its context menu and select 

the Export … command. Only the data that is currently displayed 

in the Workbook will be exported. To include other results, click 

on the asterisk * in the top left corner of the worksheet and 

select the results you want to include. 

2. Enter the File name for the spreadsheet, navigate to the folder 

where you want to save it, and then click on the Save button. By 

default, Repute will save the data in a Microsoft Excel workbook 

(*.xlsx) file. 
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3. If you open that workbook in Microsoft Excel, it should look 

something like the image below (if opened in Excel 2016). 

[Docs]\Tutorials\Tutorial 5\Tutorial 5.xlsx contains the exported data in 

Microsoft Excel format. 

Step 9 – close the project 
In Step 9, you will close and – optionally – save the project. (Note: this is not 

available in the Trial Edition.) 

1. Close the project by clicking on the File menu’s Close command. 

2. If you have made changes to the project since it was last saved, 

Repute will ask you if you want to save before proceeding. 

Answer Yes or No by clicking the appropriate button. 

3. Repute will then (if requested) save and close the project. 

 
You will find a copy of the project in its final form here: 

 
[Docs]\Tutorials\Tutorial 5\Tutorial 5.rpx 

 

What next? 
Tutorial 6 looks at the more complicated case of an asymmetric pile group 

under 3-dimensional loading. 
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Tutorial 6. Asymmetric pile group under 3D loading 
Introduction 
Tutorial 6 considers a more complicated project: that of an asymmetric pile 

group under general 3-dimensional loading. This tutorial shows you how to: 

• Modify an existing project 

• Change the location of individual piles within a pile group 

• Specify 3D loading 

The worked example involves the analysis of a group of 15 piles installed in 

stiff clay overlying dense sand. 

• The ground conditions at the site are identical to those in Tutorial 5. 

• The piles will be installed on an irregular grid, shown below. The 

spacing between adjacent rows is 3 m in the X-direction and 1.5 m in 

the Y-direction. 

• Each pile is 20 m long, 1 m in diameter, and has a Young's modulus of 

30 GPa (both axially and laterally). 

You are interested in the displacements and rotation of the pile cap under a 

combined vertical load of 50 MN, horizontal loads of 10 MN (in the X 

direction) and 7 MN (in the Y direction), and moments of 5 MNm (in the XZ 
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plane) and 3 MNm (in the YZ plane). The vertical load will be applied on the 

pile cap at the location of Pile 9. 

This tutorial is written for users of the Professional, Enterprise, and Trial 

Editions of Repute only. Users of the Standard Edition should look at Tutorials 

1-3. 

Overview 

• In Step 1, you will open and modify an existing project. 

• In Step 2, you will delete the existing pile group from the project. 

• In Step 3, you will create a new pile group. 

• In Step 4, you will move the piles to their final positions. 

• In Step 5, you will modify the actions on the pile group. 

• In Step 6, you will perform the calculation and review the results. 

• In Step 7, you will close and (optionally) save the project. 

If Repute is not already running, open the program by pressing the Windows 

key, typing Repute 2.5 in the search bar, and clicking on the Repute 

2.5 item that should appear. Once the splash screen has disappeared, 

Repute displays its Welcome screen. 

If you have an existing project open, click Close on the program’s File menu. 

(You will be prompted to save your work if you have not already done so.) 

Step 1 – open and modify an existing project 
In Step 1, you open an existing project and modify its project information. 

1. Click on the File > Open command and, in the dialog box that 

appears, navigate to the folder [Docs]\Tutorials\Tutorial 6 and 

select the file Tutorial 4.rpx (this is a copy of the file that 

was saved at the end of Tutorial 4). 
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2. Click on the Open button to open this project. 

3. In the Project Manager, 

double-click on Site 1 

to display its properties. 

Then, in the Property 

Inspector, change the 

Description to Asymmetric pile group under 3D 

loading and the Project ID to 06. 

4. Save the project under a 

different name, by 

clicking the File > Save As 

command and then 

clicking on Repute 2 file. 

In the dialog box that 

appears, change the File 

name to Tutorial 6 

and click on the Save 

button. It will 

automatically be saved in 

the folder [Docs]\Tutorials\Tutorial 6 unless you choose another 

location for it. 
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[Docs]\Tutorials\Tutorial 6\Step 1.rpx captures everything you’ve done so far. 

Step 2 – delete the existing pile group 
In Step 2, you will delete the existing pile group from the project. 

1. Right-click anywhere on the Drawing Board and select 

Plan. (Alternatively, select the Drawing Board tab on Repute’s 

ribbon and then click on the Plan button.) 

2. Increase the scale of the drawing by right-clicking on one of the 

rulers at the edge of the Drawing Board and selecting 1:50. 

(Alternatively, click on the 1:50 button on the Drawing Board 

tab.) 

3. Click on the top-left pile (Pile 1) 

in the pile group. A blue selection 

rectangle will appear with square 

handles at each corner and Pile 1 

will be highlighted in the Project 

Manager. 

4. Select Pile 1 in the Project 

Manager. Then, while holding the 

CTRL key down, select (one at a time) Pile 2, Pile 3, 

Pile 4, and Pile Group 1.  When all five items are 

highlighted, right-click on the Project Manager and select Edit > 

Delete on the pop-up menu that appears. Click Yes to All to 

confirm that you want to delete all these items from the project 

(whereupon they will disappear from both the Project Manager 

and the Drawing Board). 
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[Docs]\Tutorials\Tutorial 6\Step 2.rpx captures everything you’ve done so far. 

Step 3 – create a new pile group 
In Step 3, you will create a new pile group to replace the old one. 

1. Open the Pile Group 

Wizard by selecting the 

Wizards tab on Repute’s 

ribbon and clicking on 

the Pile Group Wizard 

button. 

2. When the Wizard appears, choose the Custom plan arrangement 

and change the number of pile rows to m = 5 by n = 3. (The 

picture on the left-hand side of the Wizard will change to show 

you a generic rectangular pile arrangement.) Enter 3000 mm as 

both the X spacing (sx) and the Y Spacing (sy) but leave the 

Cover (c) as 150 mm. 

3. Click Next to display page 2 of the Wizard. Choose (Cast-in-

place Concrete) Bored Pile as the pile type. 
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4. Click Next to display page 3. Change the Concrete class to 

C20/25 and the Diameter/Breadth to 1050 mm. By default, 

the concrete will be assigned a Young’s modulus of 30 GPa. 

5. Click Next to display page 4. Change the Embedded length (L) to 

20 m but leave the Upstand (U) as 0 m. 

6. Click Next to display page 5. Change the pile group’s X position 

(dX) to 6 m but leave its Y position (dY) as 0 m and its Rotation 

(dθ) as 0. This will move the piles in the group closer to their 

final positions. 

7. Click Next to display page 6. Tick Situation 1 to add the pile 

group to the scenario. 

8. Click Next to display the last page of the Wizard. If you wish to 

review any of the settings you have made, click Back to return to 

the relevant page. 

9. When you are ready, click Finish to generate the pile group. The 

Pile Group Wizard then: 

• creates Piles 1-15 and Pile Group 1 

• creates Concrete 2 
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• links Piles 1-15 to Concrete 2 

• adds Piles 1-15 to Pile Group 1 

• adds Pile Group 1 to Situation 1 

10. The Drawing Board will now look something like this (change the 

scale to 1:100 to see this more clearly): 

[Docs]\Tutorials\Tutorial 6\Step 3.rpx captures everything you’ve done so far. 

Step 4 – move the piles to their final positions 
In Step 4, you will move the piles to their final (asymmetric) positions. 

1. Select Pile Group 1 in the Project Manager and then, if it is 

not already visible, open the Workbook by clicking on View > 

Workbook on Repute’s ribbon. Widen the Workbook so that you 

can (see at a minimum) the columns headed General, Location, 

and Dimensions while still displaying the Drawing Board, like 

this: 
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2. In the row for Pile 2, select the cell under the column Y-

position (m) and enter the value -4.5 and press ENTER. The 

pile’s position on the Drawing Board will change automatically. 

3. Repeat the previous instruction for Pile 4. 

4. Change the Y-position (m) of: 

• Piles 7 and 9 to -1.5 m 

• Piles 12 and 14 to 1.5 m. 

• Pile 15 to 4.5 m. 

5. Finally, change the X-position (m) of Pile 15 to -3.0 m. 
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6. Back in the Property Inspector for Pile Group 1, click on the 

Resize button to enlarge the pile cap. The Drawing Board will 

now look something like this: 

[Docs]\Tutorials\Tutorial 3\Step 4.rpx captures everything you’ve done so far. 

Step 5 – modify the loads 
In Step 5, you modify the actions on the pile group. 

1. Select Force 1 in the Project Manager and then, in its 

Property Inspector, change Fz to 50 000 kN and select Pile 8 

in the Tether to ... box (this will automatically change the Depth 

of Force 1 to 0 m to match that of Pile 8). 

2. Select Force 2 in the Project Manager and, in its Property 

Inspector, change Fx to 10 000 kN, Fy to 7 000 kN, and select 

Pile 8 in the Tether to ... box. 

3. Select Moment 1 in the Project Manager and, in its Property 

Inspector, change Mx to 3 000 kN, My to 5 000 kN, and select 

Pile 8 in the Tether to ... box. 
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4.  The Drawing Board will now look something like this: 

[Docs]\Tutorials\Tutorial 6\Step 5.rpx captures everything you’ve done so far. 

Step 6 – perform and review the calculation 
In Step 6, you will perform the calculation and review the results. 

1. Right-click on Calculation 1 in the Project Manager and 

select the Build command on the pop-up menu that appears. 

Repute will perform the calculation and then change its display to 

show its Checking Desktop (which displays the Project Manager, 

Workbook, and Graph Paper). You can switch to this display at 

any time by clicking on the Check button on the View tab. The 

load vs displacement graph will now look something like this: 
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2. You can change the graph that appears on the screen by selecting 

one of the options in the Pile Group drop-down box on the 

Graph Paper tab. For example, if you select the Moment vs 

rotation option, the graph will change to look something like this: 

3. You can change the appearance of the graph by experimenting 

with the extensive set of controls provided via its Options box. To 

display this box, click on the Options button on the Graph Paper 
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tab. Click on the help button to find instructions for using this 

box to customize your graph. 

Step 7 – close the project 
In Step 7, you will close and – optionally – save the project. (Note: this is not 

available in the Trial Edition.) 

1. Close the project by clicking on the File menu’s Close command. 

2. If you have made changes to the project since it was last saved, 

Repute will ask you if you want to save before proceeding. 

Answer Yes or No by clicking the appropriate button. 

3. Repute will then (if requested) save and close the project. 

You will find a copy of the project in its final form here: 
 

[Docs]\Tutorials\Tutorial 6\Tutorial 6.rpx 
 

What next? 
Further information about the program’s capabilities can be found in the 

Repute 2.5 User Manual and the program’s built-in help system. Details of 

the theory that underpins the program’s calculations can be found in the 

Repute 2.5 Reference Manual. 

Further resources are available from the Geocentrix website: 

www.geocentrix.co.uk/repute 


